
 

COSTAZ PU



 

Page 2 of 29 
 

 

Table of Contents 
Chapter 1: File Management ............................................................................................................... 3 

Chapter 2: Productivity Tools ............................................................................................................. 7 

Chapter 3: Digital Literacy ................................................................................................................ 18 

4.6 End-of-Chapter Revision .............................................................................................................. 26 

Chapter 5: Mock Examination .......................................................................................................... 27 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

Page 3 of 29 
 

                              Chapter 1: File Management 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

1.1 Introduction to File Management 

File management is the process of organizing, storing, protecting, and retrieving files on a 
computer. 

 Why it matters: Without proper file management, important documents can be lost, 
corrupted, or accessed by unauthorized people. 

 Real-life example: Imagine a school storing exam results. If files are scattered 
randomly, teachers waste time searching. If files are compressed and encrypted, they 
are easier to send and safer to keep. 

1.2 File Compression 

Definition 

File compression reduces the size of files and folders so they take up less storage space and 
can be transferred faster. 

Types of Compression 

 Lossless compression: No data is lost. Example: ZIP files. 

 Lossy compression: Some data is removed to reduce size. Example: JPEG images, 
MP3 audio. 
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Tools 

 WinRAR 

 7-Zip 

 PowerISO 

Step-by-Step Practice 

1. Select the file/folder. 

2. Right-click → “Add to archive.” 

3. Choose compression format (.zip, .rar). 

4. Save and test extraction. 

Case Study 

A teacher wants to email 50 student assignments. Instead of sending each file separately, she 
compresses them into one ZIP file. This saves time and reduces email size. 

Learners’ Activity 

 Learners create a folder of class photos, compress it, and email it to a peer. The peer 
extracts and confirms the files. 

 Reflection: Why is compression useful in schools with limited internet bandwidth? 

1.3 File Encryption 

Definition 

Encryption protects files by converting them into unreadable formats unless unlocked with a 
password or key. 

Why it matters 

Think of student report cards. If emailed without encryption, anyone could read them. 
Encryption ensures only authorized people can access them. 

Tools 

 BitLocker 

 7-Zip 

 PowerISO 

Step-by-Step Practice 

1. Select file/folder. 

2. Apply encryption tool. 

3. Set a strong password. 

4. Share file securely (password sent separately). 
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Case Study 

A school encrypts exam results before uploading them to cloud storage. Only teachers with the 
password can access them. 

 Learners’ Activity 

 Learners encrypt a personal document, upload it to Google Drive, and share it with a 
peer. The peer must use the password to open it. 

 Reflection: What could happen if passwords are shared carelessly? 

1.4 Best Practices in File Management 

 Use clear file names (e.g., “Math_Test_Jan2026”). 

 Organize files into folders by subject or project. 

 Backup files regularly (USB, cloud storage). 

 Compress large files before sharing. 

 Encrypt sensitive files. 

1.5 WinRAR Interface 
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encryption with a lock-and-key metaphor. 

1.6 End-of-Chapter Revision 

Multiple Choice Questions 

1. Which tool is used for file compression? a) BitLocker b) WinRAR c) Gmail d) 
WhatsApp 

2. Lossless compression means: a) Some data is lost b) No data is lost c) Files cannot be 
opened d) Files are encrypted 

Short Answer Questions 

1. Explain the difference between compression and encryption. 

2. Why is encryption important in schools? 

3. Give two examples of compression tools. 

Practical Task 

 Compress a folder of documents, encrypt it with a password, and share it with a peer. 
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Chapter 2: Productivity Tools 
2.1 Word Processing  

Introduction 

Word processing is the use of software (like Microsoft Word, Libre Office Writer, 
or Google Docs) to create, edit, and format documents. It is one of the most widely 
used ICT tools in schools, businesses, and homes. 

Key Features 

 Page Setup: Adjust margins, columns, and orientation. 

 Headers & Footers: Add page numbers, titles, or author names. 

 Tables: Organize data clearly. 

 Multimedia: Insert images, charts, WordArt. 

 Hyperlinks: Connect to websites or other documents. 

 Mail Merge: Automate sending letters to multiple recipients. 

 Import/Export Styles: Maintain consistent formatting across documents. 

Case Study 

A school wants to send personalized letters to parents about exam results. Instead of typing 
each letter individually, teachers use mail merge to automatically insert each student’s name 
and marks into a template. 

         Details on key features 

📄 Page Setup: Margins, Columns, Orientation 

 Margins:  

o Go to the Layout tab. 

o Click Margins → choose a preset (Normal, Narrow, Wide) or select Custom 
Margins to set exact values. 

 Columns:  

o In the Layout tab, click Columns. 

o Choose One, Two, Three, or More Columns for custom widths and spacing. 

 Orientation:  

o Still under Layout, click Orientation. 

o Select Portrait (vertical) or Landscape (horizontal). 
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📝 Headers & Footers: Page Numbers, Titles, Author Names 

 Double-click at the top or bottom of the page to open the header/footer area. 

 Use the Header & Footer Tools tab:  

o Page Numbers → Insert → choose position (top, bottom, margins). 

o Titles/Author Names → Type directly into the header/footer area. 

o You can also insert fields (Insert → Quick Parts → Field) for dynamic info like 
date or author. 

📊 Tables: Organize Data Clearly 

 Go to the Insert tab → Table. 

 Choose:  

o Grid selection (drag to select rows/columns). 

o Insert Table → specify number of rows/columns. 

 Use Table Tools (Design & Layout tabs):  

o Apply styles (shading, borders). 

o Adjust alignment, cell size, and merge/split cells. 

o Add formulas (Layout → Formula) for calculations inside tables. 

🎨 Multimedia: Images, Charts, WordArt 

 Images: Insert → Pictures → choose from device or online. 

 Charts: Insert → Chart → pick type (bar, line, pie). Word opens Excel for editing chart 
data. 

 WordArt: Insert → WordArt → select style → type text. 

 Use Format tab to resize, crop, apply effects, or wrap text around objects. 

🔗 Hyperlinks: Connect to Websites or Documents 

 Highlight the text or select the object. 

 Right-click → Hyperlink OR Insert → Link. 

 Options:  

o Websites: Enter URL. 

o Documents: Browse to file. 

o Place in Document: Link to headings/bookmarks. 

o Email Address: Opens default mail client. 
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📬 Mail Merge: Automate Letters for Multiple Recipients 

 Go to Mailings tab → Start Mail Merge. 

 Select document type (Letters, Envelopes, Labels). 

 Click Select Recipients → choose existing list (Excel, Access, Outlook contacts). 

 Insert merge fields (e.g., «FirstName», «Address»). 

 Preview results → Finish & Merge → Print or Email. 

🎨 Import/Export Styles: Consistent Formatting 

 Import Styles:  

o Open the document → go to Design tab → Themes or Styles Pane. 

o Use Manage Styles → Import from another document/template. 

 Export Styles:  

o Save document as a Template (.dotx). 

o Other documents can apply this template to inherit styles. 

o Alternatively, copy styles via Organizer (File → Options → Add-ins → 
Templates → Organizer). 

With these tools, you can make your Word documents look professional, structured, and 
automated. 

 

Learners Activity 

 Learners design a school newsletter with: 

o A title page with images. 

o A table showing exam results. 

o A chart of attendance. 

o A hyperlink to the school website. 

 Reflection: How does mail merge save time when sending letters to parents? 
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2.2 Spreadsheets 

Introduction 

Spreadsheets (Excel, Google Sheets) are powerful tools for managing data using rows and 
columns. 

Functions 

 MIN/MAX: Find smallest/largest values. 

 COUNT/COUNTA: Count numbers or all entries. 

 SUMIF: Add values that meet specific criteria. 

Applications 

 Budgets 

 Timetables 

 Mark sheets 

 Financial records 

Formatting 

 Borders, colours, bold text for clarity. 

 Hide/unhide rows to simplify data view. 

Details 

MIN / MAX: Find Smallest & Largest Values 

 Purpose: 

o MIN(range) → returns the smallest number in a range. 

o MAX(range) → returns the largest number in a range. 

 How to Use: 

1. Enter your data in a column (e.g., student scores). 

2. In a blank cell, type: 

 =MIN(A2:A10) → finds the lowest score. 

 =MAX(A2:A10) → finds the highest score. 
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👉 🔹 COUNT / COUNTA: Count Numbers or All Entries 

 Purpose: 

o COUNT(range) → counts only numeric values. 

o COUNTA(range) → counts all non-empty cells (numbers + text). 

 How to Use: 

1. Suppose you have a mix of numbers and text. 

2. In a blank cell, type: 

 =COUNT(A2:A10) → counts how many numbers are in the list. 

 =COUNTA(A2:A10) → counts all entries (including text). 
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🔹 SUMIF: Add Values That Meet Criteria 

 Purpose: 

o SUMIF(range, criteria, sum_range) → adds values that match a condition. 

 How to Use: 

1. Suppose you have a sales table with products and amounts. 

2. In a blank cell, type: 

 =SUMIF(A2:A10,"Apples",B2:B10) → sums sales for “Apples” only. 

 =SUMIF(B2:B10,">15") → sums all values greater than 15. 

 Refer to the diagram above – It shows a sales table where only “Apple” sales are 
summed using SUMIF. 

 MIN/MAX → finding top and bottom student scores. 

 COUNT/COUNTA → counting how many students submitted assignments vs. total 
entries. 

 SUMIF → summing fees paid by students who meet certain criteria (e.g., “Paid in 
full”). 

 

Case Study 

A class is planning a trip. They use a spreadsheet to calculate transport, food, and 
accommodation costs. SUMIF helps them calculate only transport expenses. 

Learners’ Activity 

 Learners create a budget spreadsheet for a school trip. 

o Use SUMIF to calculate transport costs. 

o Format with colors for clarity. 

o Hide rows for optional expenses. 

 Reflection: Why is formatting important in financial documents? 
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2.3 Presentations  

Introduction 

A presentation package is a software application used to create slide-based displays that 
combine text, graphics, audio, video, and animations to communicate information clearly and 
attractively. Examples of presentation packages include: 

  Microsoft PowerPoint 

  Google Slides 

  Libre Office Impress  

 WPS Presentation 

          Key Features 

 Slide creation and editing. 

 Animations and transitions. 

 Multimedia insertion (images, videos, charts). 

Details 

🖼 Slide Creation and Editing 

✅ How to Do It: 

1. Open PowerPoint and choose a blank or themed template. 

2. Go to the Home tab → click New Slide to add a slide. 

3. Use Layout to choose slide type (Title, Content, Comparison, etc.). 

4. Click inside placeholders to add text, and use the Font tools to style it. 

5. Rearrange slides using the Slide Pane on the left. 

✨ Animations and Transitions 

✅ How to Do It: 

1. Select an object (text, image, shape) on a slide. 
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2. Go to the Animations tab → choose an effect like Fade, Fly In, or Zoom. 

3. Use Animation Pane to control timing and order. 

4. For slide transitions, go to the Transitions tab → choose effects like Push, Wipe, or 
Morph. 

5. Adjust Duration and click Apply to All if needed. 

 

🎥 Multimedia Insertion (Images, Videos, Charts) 

✅ How to Do It: 

1. Go to the Insert tab. 

2. Choose:  

o Pictures → from device or online. 

o Videos → from PC or YouTube. 

o Charts → select type (bar, pie, line) and edit data in Excel. 

3. Resize and position multimedia elements using drag handles. 

4. Use Format tab to apply styles, borders, and effects. 

Case Study 

Students prepare a presentation on climate change. They use images of floods, videos of 
droughts, and transitions to make the presentation engaging. 

Constructivist Activity 

 Learners prepare a presentation on climate change with: 

o Images of floods/droughts. 

o A video clip. 

o Transitions between slides. 

 Reflection: What makes a slide visually effective? 
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2.4 Publishing     

Introduction 

Microsoft Publisher is a powerful tool for designing professional publications like fliers, 
posters, calendars, business cards, and magazines. It offers intuitive layout controls, image 
handling, and shape tools to help you create visually appealing documents with ease. 

Key Features 

 Shapes, captions, images. 

 Layout design for professional communication. 

  Designing Various Publications 

Microsoft Publisher provides ready-made templates and flexible layout tools for different types 
of publications: 

Publication 
Type 

                 How to Start                 Tips 

Fliers & Posters File → New → Search “Flyer” or “Poster” 
Use bold fonts and high-contrast 
colours 

Calendars File → New → Search “Calendar” 
Customize dates and add 
personal events 

Business Cards File → New → Search “Business Card” 
Use logo, contact info, and brand 
colours 

Magazines 
File → New → Search “Newsletter” or 
“Magazine” 

Use columns, headers, and page 
numbers 

 

 Customize Layouts: Use Page Design tab to adjust margins, orientation, and guides. 

 Master Pages: For multi-page documents like magazines, use Master Pages to apply 
consistent headers, footers, and backgrounds. 

 

🖼 Inserting Images and Captions 

Adding visuals is simple and enhances your publication’s appeal: 

✅ Steps to Insert Images: 

1. Go to Insert tab → click Pictures (from device or online). 

2. Resize and position the image using drag handles. 

3. Use Picture Tools → Format to apply borders, shadows, and cropping. 
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✅ Adding Captions: 

 Insert a Text Box below or beside the image. 

 Type your caption and format it using font tools. 

 Group the image and caption together (select both → right-click → Group) to keep 
them aligned. 

🖼 Fill Shapes with Images: 

 Insert a shape (Insert → Shapes). 

 Right-click the shape → Format Shape → Shape Fill → choose Picture Microsoft 
Support. 

 

🔷 Using Shape Tools to Enhance Designs 

Shapes add structure and creativity to your layout: 

✅ Common Shape Tools: 

 Lines: Use to separate sections or underline headers. 

 Text Boxes: Insert anywhere to add custom text. 

 Shapes: Circles, rectangles, arrows, stars, etc. 

✅ How to Use: 

1. Go to Insert → Shapes. 

2. Draw the shape on your page. 

3. Use Format Shape tab to:  

o Change Fill (colour, gradient, or image). 

o Adjust Outline (colour, thickness). 

o Apply Effects (shadow, glow). 

💡 Design Tips: 

 Use alignment guides to keep elements tidy. 

 Combine shapes and text boxes for callouts or labels. 

 Use layering (right-click → Bring Forward/Send Backward) to stack elements 
creatively. 
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Case Study 

A school designs a poster for a debate competition using Publisher. They insert images, 
captions, and text boxes to make it attractive. 

Learners’ Activity 

 Learners design a poster for a school event using Publisher. 

 Reflection: How does design influence communication? 

 

End-of-Chapter Revision  

Multiple Choice Questions 

1. Which tool is best for creating a newsletter? a) Excel b) Word c) PowerPoint d) 
Publisher 

2. Which function calculates only values that meet a condition? a) COUNT b) SUMIF c) 
MAX d) MIN 

Short Answer Questions 

1. Explain the difference between COUNT and COUNTA. 

2. Why are transitions important in presentations? 

3. Give two examples of publishing tools. 

Practical Tasks 

1. Create a newsletter in Word with a table and chart. 

2. Build a spreadsheet budget for a school trip. 

3. Design a 5-slide presentation on climate change. 

4. Create a poster for a school event. 
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Chapter 3: Digital Literacy 

 

 

3.1 Introduction 

Digital literacy is the ability to use digital tools responsibly, effectively, and safely. It goes 
beyond just knowing how to use a computer—it’s about understanding communication, 
etiquette, and security in the digital world. 

Why it matters: 

 In schools, email and instant messaging are used for assignments, announcements, and 
collaboration. 

 In business, they are used for contracts, meetings, and customer service. 

 In everyday life, they connect us with friends and family. 

3.2 Email Communication  

A method for exchanging digital messages and files across devices and networks. 

3.2.1 Anatomy of an Email Address 

 Username: The unique identifier (e.g., student123). 

 Domain name: The service provider (e.g., gmail.com). 
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 Example: student123@gmail.com 

3.2.2 Types of Email Services 

 Gmail 

 Yahoo Mail 

 Outlook 

3.2.3 Email Interface 

 Inbox: Received messages. 

 Drafts: Unfinished emails. 

 Compose: Create new emails. 

 Sent: Messages already sent. 

 Outbox: Messages waiting to be sent. 

3.2.4 Sending Emails 

 Subject line: Clear and concise. 

 Body: Polite and professional. 

 Attachments: Files, images, documents. 

 

Case Study 

A teacher sends assignments via email. Students reply with attachments. The teacher organizes 
emails into folders by subject. 

Learners’ Activity 

 Learners create an email account (Gmail/Outlook). 

 Send an email to a peer with an attachment (e.g., a Word document). 

 Organize emails into folders (Assignments, Personal, School Notices). 

 Reflection: Why is organizing emails into folders important for easy retrieval? 

3.2.5 Email Etiquette 

 Avoid ALL CAPS (looks like shouting). 

 Avoid inappropriate language. 

 Do not open attachments from unknown sources. 

 Respond politely and promptly. 

      

 



 

Page 20 of 29 
 

           Learners’ Activity 

 Learners role-play sending emails: 

o One sends an email with poor etiquette (e.g., ALL CAPS, slang). 

o Another corrects it with proper etiquette. 

 Reflection: How does etiquette affect communication in academic settings? 

3.3 Instant Messaging  

Instant messaging (IM) technology is a type of synchronous computer-mediated 
communication involving the immediate (real-time) transmission of messages 

3.3.1 Introduction 

Instant messaging apps (WhatsApp, Messenger, Telegram) allow real-time communication. 

 

 

 

 

 

 

 

 

 

3.3.2 Features 

 Text messages 

 Voice notes 

 Video calls 

 Group chats 

 File sharing 

Case Study 

Students create a WhatsApp group for a science project. They share notes, images, and 
reminders. 
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           Learners’ Activity 

 Learners simulate a group project using instant messaging: 

o Create a group chat. 

o Share files and reminders. 

o Practice respectful communication. 

 Reflection: What risks exist in using instant messaging for academic work? 

3.4 Digital Safety 

 Use strong passwords. 

 Do not share personal information carelessly. 

 Be cautious of phishing emails. 

 Report suspicious messages. 

           Learners’ Activity 

 Learners analyse sample emails and identify which ones are phishing attempts. 

 Reflection: How can you protect yourself from online scams? 

3.5 Suggested Diagrams- you can incorporate the following teaching resources into your 
teaching: 

 Diagram of email structure (username + domain). 

 Screenshot of Gmail interface. 

 Flowchart of sending/receiving emails. 

 Illustration of instant messaging features. 

3.6 End-of-Chapter Revision 

Multiple Choice Questions 

1. Which part of an email address comes after the “@” symbol? a) Username b) Domain 
name c) Password d) Inbox 

2. Which of the following is NOT an instant messaging app? a) WhatsApp b) Telegram 
c) Excel d) Messenger 

Short Answer Questions 

1. Explain why ALL CAPS should be avoided in emails. 

2. What is the difference between Inbox and Outbox? 

3. Give two examples of instant messaging apps. 
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     Practical Tasks 

1. Create an email account and send a message with an attachment. 

2. Organize emails into folders. 

3. Create a WhatsApp group for a class project and share notes. 

4. Identify phishing emails from given examples. 
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CHAPTER 4: ICT IN BUSINESS 
 

4.1 Introduction 

ICT (Information and Communication Technology) has transformed the way businesses 
operate. From traditional barter systems to mobile money and online banking, ICT tools make 
transactions faster, safer, and more efficient. 

Why it matters: 

 In Zambia, mobile money services (MTN Money, Airtel Money, Zamtel Kwacha) 
allow people in rural areas to send and receive money without needing a bank account. 

 Businesses use spreadsheets and apps to budget, track expenses, and forecast profits. 

 Schools use ICT to check ECZ results online, reducing paperwork and delays. 

4.2 Evolution of Business Transactions  

 

Barter System 

 Goods exchanged directly (e.g., maize for clothes). 

 Limitations: Difficult to match needs, no standard value. 

Cash System 

 Introduction of money simplified trade. 

 Limitations: Risk of theft, need for physical presence. 

Online Banking & Mobile Money 

 Transactions done electronically. 

 Advantages: Fast, secure, accessible anywhere. 

Case Study A farmer in Southern Province sells maize to a buyer in Lusaka. Instead of 
traveling with cash, the buyer pays via mobile money. The farmer receives funds instantly. 
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Learners’ Activity 

 Learners role-play a barter trade (exchange pens for notebooks). 

 Then simulate a mobile money transaction using mock accounts. 

 Reflection: How has ICT solved the problems of barter and cash systems? 

4.3 Electronic Business Tools  

Mobile Money Services 

 MTN Money, Airtel Money, Zamtel Kwacha. 

 Used for sending/receiving money, paying bills, buying airtime. 

Online Banking 

 Access accounts via apps or websites. 

 Services: Transfers, bill payments, balance checks. 

Spreadsheets (Excel, Google Sheets) 

 Used for budgeting, expense tracking, profit analysis. 

Other Tools 

 Online checking of ECZ results. 

 E-commerce platforms (Jumia, Amazon). 

Case Study A small shopkeeper uses Airtel Money to pay suppliers and Excel to track monthly 
expenses. This reduces errors and saves time. 

Learners’ Activity 

 Learners simulate an online transaction: 

o One acts as shopkeeper, another as buyer. 

o Payment made via mobile money. 

o Transaction recorded in a spreadsheet. 

 Reflection: Why is it important to record transactions digitally? 

4.4 Budgeting with ICT  

Definition 

Budgeting is planning how money will be spent. ICT tools make budgeting easier and more 
accurate. 

Steps in Budgeting 

1. List income sources. 

2. List expenses. 
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3. Use spreadsheet formulas to calculate totals. 

4. Compare income vs. expenses. 

Case Study 

A school uses Excel to budget for a sports day. They list costs (transport, food, equipment) and 
calculate totals. 

Constructivist Activity 

 Learners create a budget spreadsheet for a class trip. 

 Use SUMIF to calculate food costs only. 

 Reflection: How does ICT improve accuracy in budgeting compared to manual 
methods? 

4.5 Suggested Diagrams for teaching aids: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Timeline showing evolution: barter → cash → online banking → mobile money. 

 Screenshot of Airtel Money interface. 

 Sample Excel budget sheet. 
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4.6 End-of-Chapter Revision 
Multiple Choice Questions 

1. Which of the following is NOT a mobile money service in Zambia? a) MTN Money b) 
Airtel Money c) Zamtel Kwacha ) PayPal 

2. Which tool is best for budgeting? a) PowerPoint b) Excel c) WhatsApp d) Publisher 

Short Answer Questions 

1. Explain two problems of the barter system. 

2. Why is mobile money important in rural areas? 

3. Give two examples of electronic business tools. 

Practical Tasks 

1. Simulate a barter trade in class. 

2. Perform a mock mobile money transaction. 

3. Create a budget spreadsheet for a school event. 

4. Check ECZ results online (simulation). 
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Chapter 5: Mock Examination 
Instructions to Learners 

 Answer all questions. 

 Time allowed: 2 hours. 

 Section A: Multiple Choice (5 marks). 

 Section B: Short Answer (30 marks). 

 Section C: Practical Tasks (50 marks). 

Section A: Multiple Choice (5 marks) 

(Choose the correct answer. Each question carries 1 mark.) 

1. Which tool is used for file compression? a) BitLocker b) WinRAR c) Gmail d) 
WhatsApp 

2. Lossless compression means: a) Some data is lost b) No data is lost c) Files cannot be 
opened d) Files are encrypted 

3. Which of the following is NOT a spreadsheet function? a) SUMIF b) MAX c) COUNT 
d) MAIL MERGE 

4. Which part of an email address comes after the “@” symbol? a) Username b) Domain 
name c) Password d) Inbox 

5. Which of the following is a mobile money service in Zambia? a) PayPal b) MTN Money 
c) Western Union d) Bitcoin 

Section B: Short Answer Questions (30 marks) 

(Answer in 3–5 sentences. Each question carries 3 marks.) 

1. Explain the difference between file compression and file encryption. 

2. Why is mail merge important in word processing? 

3. Give two examples of spreadsheet functions and explain their use. 

4. What is email etiquette? Give two examples of good practice. 

5. Explain two problems of the barter system. 

6. Why is mobile money important in rural areas? 

7. What risks exist in opening attachments from unknown sources? 

8. How does formatting improve clarity in spreadsheets? 

9. Give two examples of publishing tools. 

10. Why is budgeting important in both personal and business contexts? 
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Section C: Practical Tasks (50 marks) 

(Perform the tasks on a computer. Each task carries 10 marks.) 

1. File Management 

o Compress a folder of documents. 

o Encrypt the compressed file with a password. 

o Share it with a peer. 

2. Word Processing 

o Create a newsletter in Word. 

o Include a table of exam results, a chart of attendance, and a hyperlink to the 
school website. 

3. Spreadsheets 

o Build a budget spreadsheet for a school trip. 

o Use SUMIF to calculate food costs only. 

o Format the sheet with colors and borders. 

4. Presentations 

o Create a 5-slide presentation on climate change. 

o Include images, a video clip, and transitions. 

5. ICT in Business 

o Simulate a mobile money transaction. 

o Record the transaction in a spreadsheet. 

o Reflect on how ICT improves business efficiency. 
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Assessment Rubrics 

 Knowledge (30%): Understanding of concepts. 

 Skills (40%): Ability to perform practical tasks. 

 Application (20%): Relating ICT to real-life situations. 

 Attitude (10%): Collaboration, etiquette, and responsible use of ICT. 

 

             Project Ideas 

 School Newsletter Project: Students collaborate to design a newsletter using Word. 

 Budgeting Project: Students create a class trip budget in Excel. 

 Presentation Project: Students prepare a multimedia presentation on environmental 
issues. 

 Poster Design Project: Students design posters for a school event using 
Publisher/Canva. 

 Business Simulation Project: Students simulate mobile money transactions and record 
them in spreadsheets. 

NOTE TO TEACHERS: This masterpiece is a summarised content and activities are 
based on constructivist theory. You can add more including teaching resources to 
support your teaching. The material is not exhaustive, but a guide.  
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